journal article·2023-06-08Open access

Escaping Printable Encoded Streams to Embed Out-of-Band Data

Marco Botta, Davide Cavagnino

Applied Sciences· Volume 13· Issue 12

Abstract

In this paper, we propose to exploit the unused configurations of a printable encoding such as Base41, Base45 or Base85 to create a side channel that can store extra data such as error detection or correction codes, integrity verification and authentication information or application defined data. After introducing the encoding of binary octet strings in printable form, we present some case studies that show possible applications of the unused configurations.
Source: crossref · Quality: baseline

Research context

OpenAlex topics: Advanced Data Storage Technologies · Algorithms and Data Compression · DNA and Biological Computing

SciVX discovery tags are terminology-based. OpenAlex topics are source-provided classifications.

Affiliations

Dipartimento di Informatica, Università degli Studi di Torino, Corso Svizzera 185, 10149 Torino, Italy

Funding

Italian Ministero dell’Università e della Ricerca

References (21)

Show source-provided references
1. Base41: A proposal for printable encoding of bit strings10.1002/eng2.12606 ↗
2. Botta, M., and Cavagnino, D. (2023, May 02). Base41: A Method for Bit String Encoding in Printable Form. Available online: https://watermarking.di.unito.it/base41.html.
3. Josefsson, S. (2006). RFC 4648, RFC Editor. The Base16, Base32, and Base64 Data Encodings.10.17487/rfc4648 ↗
4. Veljkovic, S. (2023, March 27). Base41. Available online: https://github.com/sveljko/base41.
5. Fältström, P., Ljunggren, F., and van Gulik, D.W. (2022). RFC 9285, RFC Editor. The Base45 Data Encoding.10.17487/RFC9285 ↗
6. Botta, M., and Cavagnino, D. (2022). A Framework for Reversible Data Embedding into Base45 and Other Non-Base64 Encoded Strings. Appl. Sci., 12.10.3390/app12010241 ↗
7. Botta, M., and Cavagnino, D. (2023). Improving data embedding capacity into Base45 encoded strings. Eng. Rep., e12622.10.1002/eng2.12622 ↗
8. Elz, R. (1996). RFC 1924, RFC Editor. A Compact Representation of IPv6 Addresses.10.17487/rfc1924 ↗
9. Adobe Systems Incorporated (1999). PostScript Language Reference, Addison-Wesley Longman Publishing Co., Inc.. [3rd ed.].
10. Henke, J. (2023, April 28). basE91 Encoding. Available online: https://base91.sourceforge.net/.
11. He, D., Sun, Y., Jia, Z., Yu, X., Guo, W., He, W., Qi, C., and Lu, X. (July, January 29). A Proposal of Substitute for Base85/64–Base91. Proceedings of the Proceedings of the SUMMER 8th International Conference on Computing, Communications and Control Technologies: CCCT, 2010, Orlando, FL, USA.
12. UniSpaCh: A text-based data hiding method using Unicode space characters10.1016/j.jss.2011.12.023 ↗
13. A New Steganographic Method for Data Hiding in Microsoft Word Documents by a Change Tracking Technique10.1109/TIFS.2006.890310 ↗
14. A New Text Steganography Method By Using Non-Printing Unicode Characters10.30684/etj.28.1.7 ↗
15. A hybrid text steganography approach utilizing Unicode space characters and zero-width character
16. Robust and Transparent Color Modulation for Text Data Hiding10.1109/TMM.2008.2007294 ↗
17. Cyclic Codes for Error Detection10.1109/JRPROC.1961.287814 ↗
18. Koopman, P. (2023, May 02). Best CRC Polynomials. Available online: https://users.ece.cmu.edu/~koopman/crc/.
19. Rivest, R.L. (1992). RFC 1321, RFC Editor. The MD5 Message-Digest Algorithm.10.17487/rfc1321 ↗
20. Dworkin, M. (2015). SHA-3 Standard: Permutation-Based Hash and Extendable-Output Functions, National Institute of Standards and Technology.10.6028/NIST.FIPS.202 ↗
21. (1995). Secure Hash Standard. (Standard No. FIPS Pub 180-1).