journal article·2023-03-08Open access

Evaluation and Improvement of Internet Printing Protocol Based on HCPN Model Detection Method

Tao Feng, Hong-Ru Bei

Applied Sciences· Volume 13· Issue 6

Abstract

The Internet Printing Protocol (IPP) is a bridge between hosts and printers, and is supported by more than 98 percent of printers today. In addition to supporting local use, the IPP protocol also supports online use. Although this can expand the scope of its application, it has also introduced potential risks to user data. IPP has security components that should be able to guarantee confidentiality, integrity, and non-repudiation. In order to verify whether its security components can achieve this goal, this study modeled the 0-RTT authentication process of the IPP protocol based on Petri net theory and CPN Tools, introducing the improved Dolev–Yao adversary model to perform security evaluation on the protocol model. The result showed that the server could not resist the adversary’s replay attacks on early data. Accordingly, we proposed an improved authentication scheme that introduced a random number signature to enhance the server’s anti-replay capability. Using the same attack model to verify, the result proved that the new scheme was feasible and effective. The method used in this article could easily observe the movement of the security protocol message flow and the specific actions of each participant (including the adversary), which ensured researchers could easily locate the protocol defects and make improvements.
Source: crossref · Quality: baseline

Research context

OpenAlex topics: Advanced Authentication Protocols Security · User Authentication and Security Systems · Cloud Data Security Solutions

SciVX discovery tags are terminology-based. OpenAlex topics are source-provided classifications.

Affiliations

School of Computer and Communication, Lanzhou University of Technology, No. 36, Pengjiaping Road, Qilihe District, Lanzhou 730050, China

Funding

National Natural Science Foundation of China

References (38)

Show source-provided references
1. (2023, March 04). Print-Security-Market-Trends-2022, Available online: https://quocirca.com/content/quocirca-print-security-landscape-2022-press-release/.
2. (2023, March 04). IPP Everywhere, Available online: https://pwg.org/ipp/everywhere.html.
3. Michael, S. (2023, March 04). CUPS Plenary, Joint PWG/Open Printing Meeting, Sunnyvale, California, Available online: https://ftp.pwg.org/pub/pwg/liaison/openprinting/presentations/cups-plenary-may-18.pdf.
4. Petri nets: Properties, analysis and applications10.1109/5.24143 ↗
5. Jensen, K. (1987). Petri Nets: Central Models and Their Properties, Springer.
6. Colored Petri nets: A graphical language for formal modeling and validation of concurrent systems10.1145/2663340 ↗
7. On the security of public key protocols10.1109/TIT.1983.1056650 ↗
8. Cervesato, I. (2001, January 16–19). The Dolev–Yao intruder is the most powerful attacker. Proceedings of the 16th Annual Symposium on Logic in Computer Science—LICS, Boston, MA, USA.
9. Coloured Petri Nets and CPN Tools for modelling and validation of concurrent systems10.1007/s10009-007-0038-x ↗
10. Sweet, M., and McDonald, I. (2023, March 04). Internet Printing Protocol/1.1: Encoding and Transport. RFC 8010, 2017, Available online: https://www.rfc-editor.org/rfc/rfc8010.html.
11. Sweet, M., and McDonald, I. (2023, March 04). Internet Printing Protocol/1.1: Model and Semantics. RFC 8011, 2017, Available online: https://www.rfc-editor.org/rfc/rfc8011.html.
12. Wright, D. (2023, March 04). Design Goals for an Internet Printing Protocol. RFC 2567, 1999, Available online: https://www.rfc-editor.org/rfc/rfc2567.html.
13. Zilles, S.N. (2023, March 04). Rationale for the Structure of the Model and Protocol for the Internet Printing Protocol. RFC 2568, 1999, Available online: https://www.rfc-editor.org/rfc/rfc2568.html.
14. Khare, R., and Lawrence, S. (2023, March 04). Upgrading to TLS within HTTP/1.1. RFC 2817, 2000, Available online: https://www.rfc-editor.org/rfc/rfc2817.10.17487/rfc2817 ↗
15. Herriot, R., and McDonald, I. (2023, March 04). Internet Printing Protocol/1.1: IPP URL Scheme. RFC 3510, 2003, Available online: https://www.rfc-editor.org/rfc/rfc3510.html.10.17487/rfc3510 ↗
16. McDonald, I., and Sweet, M. (2023, March 04). Internet Printing Protocol (IPP) over HTTPS Transport Binding and the ’IPPS’ URI Scheme. RFC 7472, 2015, Available online: https://www.rfc-editor.org/rfc/rfc7472.html.10.17487/rfc7472 ↗
17. Rizk-Allah, R.M., Abdulkader, H., Elatif, S.S.A., Elkilani, W.S., Al Maghayreh, E., Dhahri, H., and Mahmood, A. (2022). A Novel Binary Hybrid PSO-EO Algorithm for Cryptanalysis of Internal State of RC4 Cipher. Sensors, 22.10.3390/s22103844 ↗
18. Amodei, A., Capriglione, D., Ferrigno, L., Miele, G., Tomasso, G., and Cerro, G. (2022, January 18–20). A rule-based approach for detecting heartbleed cyber attacks. Proceedings of the 2022 IEEE International Symposium on Measurements & Networking (M&N), Padua, Italy.10.1109/MN55117.2022.9887776 ↗
19. Al Fardan, N.J., and Paterson, K.G. (2013, January 19–22). Lucky thirteen: Breaking the TLS and DTLS record protocols. Proceedings of the 2013 IEEE Symposium on Security and Privacy, Berkeley, CA, USA.10.1109/SP.2013.42 ↗
20. Adrian, D., Bhargavan, K., Durumeric, Z., Gaudry, P., Green, M., Halderman, J.A., Heninger, N., Springall, D., Thomé, E., and Valenta, L. (2015, January 12–16). Imperfect forward secrecy: How Diffie-Hellman fails in practice. Proceedings of the 22nd ACM SIGSAC Conference on Computer and Communications Security, Denver, CO, USA.10.1145/2810103.2813707 ↗
21. Diffie-Hellman key exchange modification using blowfish algorithm to prevent logjam attack
22. A comprehensive and critical analysis of TLS 1.3
23. Langley, A., Riddoch, A., Wilk, A., Vicente, A., Krasic, C., Zhang, D., Yang, F., Kouranov, F., Swett, I., and Iyengar, J. (2017, January 21–25). The quic transport protocol: Design and internet-scale deployment. Proceedings of the Conference of the ACM Special Interest Group on Data Communication, Los Angeles, CA, USA.10.1145/3098822.3098842 ↗
24. Secure communication channel establishment: TLS 1.3 (over TCP fast open) versus QUIC10.1007/s00145-021-09389-w ↗
25. Session resumption protocols and efficient forward security for TLS 1.3 0-RTT10.1007/s00145-021-09385-0 ↗
26. Aziz, B., and Aziz, B. (2022). Formal Analysis by Abstract Interpretation, Springer.10.1007/978-3-030-91153-9 ↗
27. Proving mutual authentication property of rcia protocol in rfid based on logic of events
28. Formal Analysis and Optimization of TLS1. 3 Protocol in Strong Security Model
29. Ram, S.B., and Odelu, V. (2022, January 26–29). Security Analysis of a Key Exchange Protocol under Dolev–Yao Threat Model Using Tamarin Prover. Proceedings of the 2022 IEEE 12th Annual Computing and Communication Workshop and Conference (CCWC), Las Vegas, NV, USA.10.1109/CCWC54503.2022.9720852 ↗
30. Du, J., Gao, C., and Feng, T. (2022). Formal Safety Assessment and Improvement of DDS Protocol for Industrial Data Distribution Service. Future Internet, 15.10.3390/fi15010024 ↗
31. Petri, C.A. (1962). Kommunikation mit Automaten. [Ph.D. Thesis, University of Hamburg].
32. Using a novel hierarchical coloured Petri net to model and optimise fleet spare inventory, cannibalisation and preventive maintenance10.1016/j.ress.2019.106579 ↗
33. Grobelna, I., and Szcześniak, P. (2022). Interpreted petri nets applied to autonomous components within electric power systems. Appl. Sci., 12.10.3390/app12094772 ↗
34. Farooq, M.S., Idrees, M., Rehman, A.U., Khan, M.Z., Abunadi, I., Assam, M., Althobaiti, M.M., and Al-Wesabi, F.N. (2022). Formal Modeling and Improvement in the Random Path Routing Network Scheme Using Colored Petri Nets. Appl. Sci., 12.10.3390/app12031426 ↗
35. Bhattacharjya, A., Wisniewski, R., and Nidumolu, V. (2022). Holistic Research on Blockchain’s Consensus Protocol Mechanisms with Security and Concurrency Analysis Aspects of CPS. Electronics, 11.10.3390/electronics11172760 ↗
36. (2023, March 04). A Tool for Editing, Simulating, and Analyzing Colored Petri Nets, Available online: http://cpntools.org/.
37. Ratzer, A.V., Wells, L., Lassen, H.M., Laursen, M., Qvortrup, J.F., Stissing, M.S., Westergaard, M., Christensen, S., and Jensen, K. (2003, January 23–27). CPN tools for editing, simulating, and analysing coloured Petri nets. Proceedings of the Applications and Theory of Petri Nets 2003: 24th International Conference, ICATPN 2003, Eindhoven, The Netherlands.10.1007/3-540-44919-1_28 ↗
38. Verbeek, E., and Fahland, D. (November, January 31). CPN IDE: An Extensible Replacement for CPN Tools That Uses Access/CPN. Proceedings of the 3rd International Conference on Process Mining Doctoral Consortium and Demo Track, ICPM-D 2021, Eindhoven, The Netherlands.