journal article·2022-07-01Open access

Design and Implementation of Semi-Physical Platform for Label Based Frame Switching in Integrated Satellite Terrestrial Networks

Wei Zhou, Xing Jiang, Qingsong Luo, Shanguo Huang, Bingli Guo, Xiang Sun, Shaobo Li, Xiaochuan Tan, Mingyi Ma, Tianwen Fu

Applied Sciences· Volume 12· Issue 13

Abstract

With the explosion of traffic demand in recent years, the integration of satellite optical networks and terrestrial networks (ISTN) creates a promising networking solution for future low-latency, high-rate, and high-capacity communications. Owing to the high cost of deploying and maintaining a satellite optical network, it is critical to carefully design and plan the network to ensure the performance of the network. Thus, a semi-physical simulation platform based on software-defined networks (SDNs) is developed to simulate a satellite optical network and evaluate the performance of the proposed label-based advanced orbiting system (AOS) frame switching method that adheres to the Consultative Committee for Space Data Systems’ recommended standard (CCSDS). The semi-physical simulation platform has two major innovations: (1) adapting and integrating network protocols between the CCSDS and open system interconnect (OSI) reference models, particularly at the data link layer, and (2) the foundation for an SDN-based satellite optical network. In the control plane, real-time VxWorks Simulators serve as controllers to establish and manage various network protocols and the link manager protocol (LMP). Here, network protocols include open shortest path first (OSPF) for routing managing and controlling messages, constraint shortest path first–traffic engineering (CSPF-TE), and constraint-label distribution protocol (CR-LDP) for routing data services. LMP is used to assign and reserve satellite optical link resources. The performance of the architecture and protocols is evaluated via a semi-physical simulation platform.
Source: crossref · Quality: baseline

Research context

OpenAlex topics: Software-Defined Networks and 5G · Advanced Optical Network Technologies · Satellite Communication Systems

SciVX discovery tags are terminology-based. OpenAlex topics are source-provided classifications.

Affiliations

School of Information and Communication, Guilin University of Electronic Technology, Guilin 541004, China

The 34th Research Institute of China Electronics Technology Group Corporation, Guilin 541004, China

State Key Laboratory of Information Photonics and Optical Communications, Beijing University of Posts and Telecommunications, Beijing 100876, China

Department of Electrical and Computer Engineering, University of New Mexico, Albuquerque, NM 87131, USA

The 54th Research Institute of China Electronics Technology Group Corporation, Shijiazhuang 050081, China

Hebei Key Laboratory of Photonics Information Technology and Application, Shijiazhuang 050081, China

Funding

GUET Excellent Graduate Thesis Program · Innovation Project of Guangxi Graduate Education · Research Institute of China Electronics Technology Group Corporation

References (19)

Show source-provided references
1. King, D., Farrel, A., and Chen, Z. (2020, January 19–23). An Evolution of Optical Network Control: From Earth to Space. Proceedings of the 2020 2nd International Conference on Transparent Optical Networks (ICTON), Bari, Italy.10.1109/ICTON51198.2020.9203098 ↗
2. Ma, Z., Zhao, Y., Wang, W., and Zhang, J. (2021, January 19–22). Demonstration of Highly Dynamic Satellite Optical Networks Supporting Rapid Reconfiguration. Proceedings of the 2021 17th International Conference on the Design of Reliable Communication Networks (DRCN), Milano, Italy.10.1109/DRCN51631.2021.9477335 ↗
3. Zhai, H., Zhang, Z., Zhang, H., Wang, B., Zhao, Y., and Zhang, J. (2021, January 23–27). Design and Implementation of the Hardware Platform of Satellite Optical Switching Node. Proceedings of the 2021 19th International Conference on Optical Communications and Networks (ICOCN), Qufu, China.10.1109/ICOCN53177.2021.9563810 ↗
4. Zhang, Y., Yuan, Y., Guo, B., Luo, Q., Zhao, B., Zhou, W., Jiang, M., Wang, Y., Fu, M., and Liu, Y. (2021). A Research Study on Protocol Stack of Space-Based Optical Backbone Network. Appl. Sci., 11.10.3390/app11052367 ↗
5. On Optimizing the Divergence Angle of an FSO-Based Fronthaul Link in Drone-Assisted Mobile Networks10.1109/JIOT.2021.3113715 ↗
6. SDN-Based End-to-End Fragment-Aware Routing for Elastic Data Flows in LEO Satellite-Terrestrial Network10.1109/ACCESS.2018.2885473 ↗
7. Guo, X., Guo, B., Li, K., Fan, C., Yang, H., and Huang, S. (2019, January 5–8). A SDN-enabled Integrated Space-Ground Information Network Simulation Platform. Proceedings of the 2019 18th International Conference on Optical Communications and Networks (ICOCN), Huangshan, China.10.1109/ICOCN.2019.8934091 ↗
8. A Survey of Software-Defined Networking: Past, Present, and Future of Programmable Networks10.1109/SURV.2014.012214.00180 ↗
9. Routing and wavelength assignment in a satellite optical network based on ant colony optimization with the small window strategy10.1364/JOCN.7.000995 ↗
10. Cao, S., and Zhang, T. (2019, January 16–19). Congestion Control Based on OSPF in LEO Satellite Constellation. Proceedings of the 2019 IEEE 19th International Conference on Communication Technology (ICCT), Xi’an, China.10.1109/ICCT46805.2019.8947269 ↗
11. Wang, Y., Chen, T., and Zhou, N. (2019, January 12–15). Space-based Optical Burst Switching Assembly Algorithm Based on QoS Adaption. Proceedings of the 2019 IEEE 11th International Conference on Communication Software and Networks (ICCSN), Chongqing, China.10.1109/ICCSN.2019.8905264 ↗
12. Aos Space Data Link Protocol (2021). CCSDS 732.0-B-4, Blue Book, CCSDS.
13. IP Over CCSDS Space Links (2012). CCSDS 702.1-B-1, Blue Book, CCSDS.
14. Andersson, L., Doolan, P., Feldman, N., Fredette, A., and Thomas, B. (2001). LDP Specification, IETF. RFC 3036.10.17487/rfc3036 ↗
15. Awduche, D., Berger, L., Gan, D., Li, T., Srinivasan, V., and Swallow, G. (2001). RSVP-TE: Extensions to RSVP for LSP Tunnels, IETF. RFC 3209.10.17487/rfc3209 ↗
16. Braden, R., Zhang, L., Berson, S., Herzog, S., and Jamin, S. (1997). Resource ReSerVation Protocol (RSVP)—Version 1 Functional Specification, IETF. RFC 2205.10.17487/rfc2209 ↗
17. Jamoussi, B., Andersson, L., Callon, R., Dantu, R., Wu, L., Doolan, P., Worster, T., Feldman, N., Fredette, A., and Girish, M. (2002). Constraint-Based LSP Setup Using LDP, IETF. RFC 3212.10.17487/rfc3212 ↗
18. Varga, A., and Hornig, R. (2008, January 3–7). An overview of the OMNeT++ simulation environment. Proceedings of the 1st International Conference on Simulation Tools and Techniques for Communications, Networks and Systems & Workshops, SimuTools 2008, Marseille, France.10.4108/ICST.SIMUTOOLS2008.3027 ↗
19. Fu, M., Guo, B., Yang, H., Pang, C., and Huang, S. (2022). Routing Optimization Based on OSPF in Multi-Layer Satellite Network, IOS Press.10.3233/FAIA210452 ↗