A Secure CDM-Based Data Analysis Platform (SCAP) in Multi-Centered Distributed Setting
Source abstract
Abstract
Hospitals have their own database structures and maintain their data in a closed manner. For this reason, it is difficult for researchers outside of institutions to access multi-center data. Therefore, if the data maintained by all hospitals follow a commonly shared format, researchers can analyze multi-center data using the same method. To safely analyze data using a common data model (CDM) in a distributed multi-center network environment, the objective of this study is to propose and implement the processes for distribution, executing the analysis codes, and returning the results. A secure CDM-based data analysis platform (SCAP) consists of a certificate authority (CA), authentication server (AS), code signer (CS), ticket-granting server (TGS), relaying server (RS), and service server (SS). The AS, CS, TGS, and RS form the central server group of the platform. An SS is stored on a hospital server as an agent for communication with the server group. We designed the functionalities and communication protocols among servers. To safely conduct the intended functions, the proposed protocol was implemented based on a cryptographic algorithm. An SCAP was developed as a web application running on this protocol. Users accessed the platform through a web-based interface.
Source: crossref · Quality: baseline
Research context
OpenAlex topics: Privacy-Preserving Technologies in Data · Cryptography and Data Security · Cloud Data Security Solutions
SciVX discovery tags are terminology-based. OpenAlex topics are source-provided classifications.
Affiliations
Division of Information Security, Graduate School of Information Security, Korea University, Seoul 02841, Korea
Funding
Korea Health Industry Development Institute
References (38)
Show source-provided references
1. Liu, J., Li, X., Ye, L., Zhang, H., Du, X., and Guizani, M. (2018, January 9–13). BPDS: A Blockchain Based Privacy-Preserving Data Sharing for Electronic Medical Records. Proceedings of the 2018 IEEE Global Communications Conference (GLOBECOM), Abu Dhabi, United Arab Emerites.10.1109/GLOCOM.2018.8647713 ↗
2. Security Techniques for the Electronic Health Records10.1007/s10916-017-0778-4 ↗
3. Multi-source medical data integration and mining for healthcare services10.1109/ACCESS.2020.3023332 ↗
4. Deng, Y., Li, Y., Shen, Y., Du, N., Fan, W., Yang, M., and Lei, K. (2019, January 3–7). MedTruth: A semi-supervised approach to discovering knowledge condition information from multi-source medical data. Proceedings of the 28th ACM International Conference on Information and Knowledge Management, Beijing, China.10.1145/3357384.3357934 ↗
5. Ranbaduge, T., Vatsalan, D., Christen, P., and Verykios, V. (2016). Hashing-based distributed multi-party blocking for privacy-preserving record linkage. Lecture Notes in Computer Science, Proceedings of the Pacific-Asia Conference on Knowledge Discovery and Data Mining, Auckland, New Zealand, 19–22 April 2016, Springer.10.1007/978-3-319-31750-2_33 ↗
6. Vatsalan, D., and Christen, P. (2014, January 3–7). Scalable privacy-preserving record linkage for multiple databases. Proceedings of the 23rd ACM International Conference on Conference on Information and Knowledge Management, Shanghai, China.10.1145/2661829.2661875 ↗
7. OHDSI (2021, September 29). OMOP Common Data Model. Available online: https://www.ohdsi.org/data-standardization/the-common-data-model/.
8. Sentinel Initiative (2021, September 29). Sentinel Common Data Model. Available online: https://www.sentinelinitiative.org/methods-data-tools/sentinel-common-data-model.
9. PCORI (2021, September 29). PCORnet. Available online: https://pcornet.org/data/.
10. Dierks, T., and Rescorla, E. (2008). RFC 5246: The Transport Layer Security (TLS) Protocol—Version 1.2, International Engineering Task Force (IETF).10.17487/rfc5246 ↗
11. A survey of extract-transform-load technology10.4018/jdwm.2009070101 ↗
12. Validating the extract, transform, load process used to populate a large clinical research database10.1016/j.ijmedinf.2016.07.009 ↗
13. Utility-preserving anonymization for health data publishing10.1186/s12911-017-0499-0 ↗
14. Privacy and utility preserving data clustering for data anonymization and distribution on Hadoop10.1016/j.future.2016.10.022 ↗
15. OHDSI (2021, September 29). ATLAS-A Unified Interface for the OHDSI Tools. Available online: https://www.ohdsi.org/atlas-a-unified-interface-for-the-ohdsi-tools/.
16. Yao, X., Lin, Y., Liu, Q., and Long, S. (2015, January 6–9). Efficient and privacy-preserving search in multi-source personal health record clouds. Proceedings of the IEEE Symposium on Computers and Communication (ISCC), Larnaca, Cyprus.10.1109/ISCC.2015.7405612 ↗
17. Woong Park, R. (2020). A Clinical Real-World Evidence Sharing Platform Over the Globe. J. Acupunct. Meridian Stud., 13.10.1016/j.jams.2020.03.004 ↗
18. ISO (2021, September 29). ISO 27799: 2016-Health Informatics-Information Security Management in Health Using ISO/IEC 27002. International Organization for Standardization (ISO)., Available online: https://www.iso.org/standard/62777.html.
19. Jones, M., Bradley, J., and Sakimura, N. (2015). RFC 7519: Json Web Token (JWT), Internet Engineering Task Force (IETF).10.17487/RFC7519 ↗
20. Hardt, D. (2012). RFC 6749: The OAuth 2.0 Authorization Framework, International Engineering Task Force (IETF).10.17487/rfc6749 ↗
21. The Elliptic Curve Digital Signature Algorithm (ECDSA)10.1007/s102070100002 ↗
22. Cao, Y.Y., and Fu, C. (2008, January 20–22). An efficient implementation of RSA digital signature algorithm. Proceedings of the 2008 International Conference on Intelligent Computation Technology and Automation (ICICTA), Changsha, China.10.1109/ICICTA.2008.398 ↗
23. Neuman, C., Yu, T., Hartman, S., and Raeburn, K. (2005). RFC 4120: The Kerberos Network Authentication Service (V5), International Engineering Task Force (IETF).10.17487/rfc4120 ↗
24. MEDCO: Enabling secure and privacy-preserving exploration of distributed clinical and genomic data10.1109/TCBB.2018.2854776 ↗
25. The future of digital health with federated learning10.1038/s41746-020-00323-1 ↗
26. Federated machine learning: Concept and applications10.1145/3339474 ↗
27. Federated Learning for Healthcare Informatics10.1007/s41666-020-00082-4 ↗
28. A distributed ensemble approach for mining healthcare data under privacy constraints10.1016/j.ins.2015.10.011 ↗
29. Gruendner, J., Schwachhofer, T., Sippl, P., Wolf, N., Erpenbeck, M., Gulden, C., Kapsner, L.A., Zierk, J., Mate, S., and Stürzl, M. (2019). Ketos: Clinical decision support and machine learning as a service—A training and deployment platform based on Docker, OMOP-CDM, and FHIR Web Services. PLoS ONE, 14.10.1371/journal.pone.0225442 ↗
30. OHDSI (2021, September 29). OHDSIonAWS-Automation Code and Documentation for Standing Up the OHDSI Toolstack in an AWS Environment. Available online: https://github.com/OHDSI/OHDSIonAWS.
31. Kim, G.L., Yi, Y.H., Hwang, H.R., Kim, J., Park, Y., Kim, Y.J., Lee, J.G., Tak, Y.J., Lee, S.H., and Lee, S.Y. (2021). The Risk of Osteoporosis and Osteoporotic Fracture Following the Use of Irritable Bowel Syndrome Medical Treatment: An Analysis Using the OMOP CDM Database. J. Clin. Med., 10.10.3390/jcm10092044 ↗
32. Analysis of treatment pathways for three chronic diseases using OMOP CDM10.1007/s10916-018-1076-5 ↗
33. Forsby, F., Furuhed, M., Papadimitratos, P., and Raza, S. (2017). Lightweight X.509 Digital Certificates for the Internet of Things. Lecture Notes of the Institute for Computer Sciences, Social Informatics and Telecommunications Engineering, Proceedings of the International Conference on Safety and Security in IoT, Valencia, Spain, 6–7 November 2017, Springer.10.1007/978-3-319-93797-7_14 ↗
34. Plata, I.T., Panganiban, E.B., and Bartolome, B.B. (2019). A security approach for file management system using data encryption standard (DES) algorithm. Int. J. Adv. Trends Comput. Sci. Eng., 8.10.30534/ijatcse/2019/30852019 ↗
35. The advanced encryption standard10.1080/0161-110291890876 ↗
36. OHDSI (2021, September 29). HADES-Health Analytics Data-to-Evidence Suite. Available online: https://ohdsi.github.io/Hades/.
37. Securing Wireless Sensor Networks Against Denial-of-Sleep Attacks Using RSA Cryptography Algorithm and Interlock Protocol10.1002/dac.4234 ↗
38. Gennaro, R., and Goldfeder, S. (2018, January 15–19). Fast multiparty threshold ECDSA with fast trustless setup. Proceedings of the 2018 ACM SIGSAC Conference on Computer and Communications Security, Toronto, ON, Canada.10.1145/3243734.3243859 ↗