A Distributed Multicast QoS Routing Construction Approach in Information-Centric Networking
Source abstract
Abstract
Many applications suitable for multicast transmission, such as video conferencing and live e-commerce, demand high Quality of Service (QoS) and require data delivery to be completed within specified delay constraints. Some methods have been proposed for constructing delay-constrained multicast routing based on network state. However, obtaining precise network latency can be challenging, resulting in inaccuracies in delay-constrained routing calculations and, ultimately, the inability to meet application requirements. Additionally, many methods engage in an indiscriminate exploration of potential paths in the network, causing significant message processing overhead. This paper proposes an Information-Centric Networking (ICN)-based approach for delay-constrained multicast routing. Our method dynamically constructs multicast paths from tree nodes to receivers based on real-time path status detection during the join message propagation phase. Additionally, we present a method for acquiring neighborhood state information to facilitate real-time routing decisions. To curtail indiscriminate path exploration, our approach uses the ICN Name Resolution System (NRS) to obtain and select potential optimal tree nodes. For this purpose, we design a multicast service registration and resolution mechanism using the ICN Name Resolution System (NRS). Simulation results indicate that our approach exhibits a higher success ratio and concurrently incurs lower message processing overhead than some other methods, particularly in situations with stringent delay constraints.
Source: crossref · Quality: baseline
Research context
OpenAlex topics: Caching and Content Delivery · Cooperative Communication and Network Coding · Opportunistic and Delay-Tolerant Networks
SciVX discovery tags are terminology-based. OpenAlex topics are source-provided classifications.
Affiliations
National Network New Media Engineering Research Center, Institute of Acoustics, Chinese Academy of Sciences, No. 21, North Fourth Ring Road, Haidian District, Beijing 100190, China
School of Electronic, Electrical and Communication Engineering, University of Chinese Academy of Sciences, No. 19(A), Yuquan Road, Shijingshan District, Beijing 100049, China
Funding
Institute of Acoustics, Chinese Academy of Sciences: Research on transmission technology for information center network
References (46)
Show source-provided references
1. Li, J., Li, Z., Lu, R., Xiao, K., Li, S., Chen, J., Yang, J., Zong, C., Chen, A., and Wu, Q. (2022, January 22–26). LiveNet: A Low-Latency Video Transport Network for Large-Scale Live Streaming. Proceedings of the ACM SIGCOMM 2022 Conference, Amsterdam, Netherlands. SIGCOMM ’22.10.1145/3544216.3544236 ↗
2. 1174: Futuristic trends and innovations in multimedia systems using big data, IoT and cloud technologies (FTIMS)10.1007/s11042-022-13753-8 ↗
3. Group Communications in Narrowband-IoT: Architecture, Procedures, and Evaluation10.1109/JIOT.2018.2807619 ↗
4. Bull, D.R., and Zhang, F. (2021). Intelligent Image and Video Compression, Academic Press. [2nd ed.].
5. Multicast Communication on Network Computers10.1109/MS.1985.230701 ↗
6. Deering, S.E. (1988, January 16–18). Multicast Routing in Internetworks and Extended LANs. Proceedings of the Symposium Proceedings on Communications Architectures and Protocols, Stanford, CA, USA. SIGCOMM ’88.10.1145/52324.52331 ↗
7. A Quality of Service Architecture10.1145/185595.185648 ↗
8. Multicast routing algorithms and protocols: A tutorial10.1109/65.819175 ↗
9. A distributed multicast routing algorithm for real-time applications in wide area networks10.1016/j.jpdc.2007.01.007 ↗
10. RSVP: A New Resource ReSerVation Protocol10.1109/MCOM.2002.1006981 ↗
11. Yuan, X., Zheng, W., and Ding, S. (2002, January 16). A comparative study of QoS routing schemes that tolerate imprecise state information. Proceedings of the Eleventh International Conference on Computer Communications and Networks, Miami, FL, USA.
12. Sanguankotchakorn, T., and Perera, N. (2010, January 11–16). Hybrid Multi-constrained Optimal Path QoS Routing with Inaccurate Link State. Proceedings of the 2010 Ninth International Conference on Networks, Menuires, France.10.1109/ICN.2010.57 ↗
13. Routing of multipoint connections10.1109/49.12889 ↗
14. Steiner problem in networks: A survey10.1002/net.3230170203 ↗
15. Garey, M.R., and Johnson, D.S. (1990). Computers and Intractability; A Guide to the Theory of NP-Completeness, W. H. Freeman & Co.
16. Oliveira, C.A.S., and Pardalos, P.M. (2011). Mathematical Aspects of Network Routing Optimization, Springer.10.1007/978-1-4614-0311-1 ↗
17. Named Data Networking10.1145/2656877.2656887 ↗
18. A survey of information-centric networking10.1109/MCOM.2012.6231276 ↗
19. A Survey of Information-Centric Networking Research10.1109/SURV.2013.070813.00063 ↗
20. A review of information centric network-based internet of things: Communication architectures, design issues, and research opportunities10.1007/s11042-018-6943-z ↗
21. A survey of naming and routing in information-centric networks10.1109/MCOM.2012.6384450 ↗
22. Jacobson, V., Smetters, D.K., Thornton, J.D., Plass, M.F., Briggs, N.H., and Braynard, R.L. (2009, January 1–4). Networking Named Content. Proceedings of the 5th International Conference on Emerging Networking Experiments and Technologies, Rome, Italy. CoNEXT ’09.10.1145/1658939.1658941 ↗
23. Zeng, L., Ni, H., and Han, R. (2020). An Incrementally Deployable IP-Compatible-Information-Centric Networking Hierarchical Cache System. Appl. Sci., 10.10.3390/app10186228 ↗
24. MobilityFirst: A Mobility-Centric and Trustworthy Internet Architecture10.1145/2656877.2656888 ↗
25. SEANet: Architecture and Technologies of an On-site, Elastic, Autonomous Network
26. Survey on the Name Resolution Technologies in Information Centric Networking
27. Crawley, E., Nair, R., Rajagopalan, B., and Sandick, H. (1998, August 01). RFC 2386: A Framework for QoS-Based Routing in the Internet. Available online: https://www.rfc-editor.org/rfc/rfc2386.10.17487/rfc2386 ↗
28. Apostolopoulos, G., Kama, S., Williams, D., Guerin, R., Orda, A., and Przygienda, T. (1999, August 01). RFC 2676: QoS Routing Mechanisms and OSPF Extensions. Available online: https://www.rfc-editor.org/rfc/rfc2676.10.17487/rfc2676 ↗
29. Multicast routing and its QoS extension: Problems, algorithms, and protocols10.1109/65.819168 ↗
30. Riley, G.F., and Henderson, T.R. (2010). Modeling and Tools for Network Simulation, Springer.
31. Deering, S.E. (1989, August 01). RFC 1112: Host Extensions for IP Multicasting. Available online: https://www.rfc-editor.org/rfc/rfc1112.10.17487/rfc1112 ↗
32. Providing sustainable QoS in next-generation networks10.1109/MCOM.2004.1304243 ↗
33. Deering, S., Estrin, D., Farinacci, D., Jacobson, V., Liu, C.G., and Wei, L. (September, January 31). An Architecture forWide-Area Multicast Routing. Proceedings of the Conference on Communications Architectures, Protocols and Applications, London, UK. SIGCOMM ’94.
34. A fast algorithm for Steiner trees10.1007/BF00288961 ↗
35. Shortest connection networks and some generalizations10.1002/j.1538-7305.1957.tb01515.x ↗
36. Zhu, Q., Parsa, M., and Garcia-Luna-Aceves, J. (1995, January 2–6). A source-based algorithm for delay-constrained minimum-cost multicasting. Proceedings of the INFOCOM’95, Boston, MA, USA.
37. A distributed algorithm of delay-bounded multicast routing for multimedia applications in wide area networks10.1109/90.748092 ↗
38. Comments and an improvement on “A distributed algorithm of delay-bounded multicast routing for multimedia applications in wide area Networks”10.1109/TNET.2005.860091 ↗
39. Optimal multicast routing with quality of service constraints10.1007/BF02139130 ↗
40. Building Shared Trees Using a One-to-Many Joining Mechanism10.1145/251007.251008 ↗
41. QoS-aware multicast routing for the Internet: The design and evaluation of QoSMIC10.1109/90.986530 ↗
42. A QoS-aware multicast routing protocol10.1109/49.898738 ↗
43. A Data-Oriented (and beyond) Network Architecture10.1145/1282427.1282402 ↗
44. Tomkos, I., Bouras, C.J., Ellinas, G., Demestichas, P., and Sinha, P. (2010, January 25–27). Developing Information Networking Further: From PSIRP to PURSUIT. Proceedings of the Broadband Communications, Networks, and Systems, Athens, Greece.
45. Mukherjee, S., Bronzino, F., Srinivasan, S., Chen, J., and Raychaudhuri, D. (2016, January 4–8). Achieving Scalable Push Multicast Services Using Global Name Resolution. Proceedings of the 2016 IEEE Global Communications Conference (GLOBECOM), Washington, DC, USA.10.1109/GLOCOM.2016.7841564 ↗
46. Yang, B., Chen, X., Xie, J., Li, S., Zhang, Y., and Yang, J. (2019, January 18–21). Multicast Design for the MobilityFirst Future Internet Architecture. Proceedings of the 2019 International Conference on Computing, Networking and Communications (ICNC), Honolulu, HI, USA.10.1109/ICCNC.2019.8685485 ↗