An IP Multimedia Subsystem Services Proxy Gateway Based on a JAVA Dynamic Module System
Source abstract
Abstract
By virtue of the rapid development of the Information and Communication Technology (ICT), people have owned various devices connected to the Internet to enjoy various emerging application services, such as multimedia related services. IP Multimedia Subsystem (IMS) is the integration platform for multimedia application services and provides a rich feature set of converged services in the Next Generation Network (NGN). IMS services are accessed by a user anytime and anywhere through his/her personal self IMS device, e.g., mobile device, equipped with a Universal Subscriber Identity Module (USIM) card. People have owned various devices connected to the Internet at homes or offices. However, some devices can not access IMS services without USIM cards embedded, which is called non-IMS devices. People wish that more devices without USIM cards embedded should be connected to the Internet on which IMS services are accessed in addition to the mobile devices equipped with USIM cards. Accordingly, we propose an Open Service Gateway Initiative (OSGi)-based IMS service gateway, in which OSGi technology is the dynamic module system for JAVA. The proposed gateway is authorized by a personal self IMS device such that IMS services are accessed by non-IMS devices, in this paper. Moreover, these non-IMS devices rely on different networks to access technologies and network protocols and the IMS service gateway proposed here adopts the OSGi framework for no problem of integration.
Source: crossref · Quality: baseline
Research context
OpenAlex topics: IPv6, Mobility, Handover, Networks, Security · Multimedia Communication and Technology · Cloud Computing and Remote Desktop Technologies
SciVX discovery tags are terminology-based. OpenAlex topics are source-provided classifications.
Affiliations
Department of Computer Science and Information Engineering, Hungkuang University, Taichung City 43302, Taiwan
Department of Information and Communication Engineering, Chaoyang University of Technology, Taichung City 41349, Taiwan
References (25)
Show source-provided references
1. Camarillo, G., and Garcia-Martin, M.A. (2008). Wiley InterScience (Online Service). The 3G IP Multimedia Subsystem (IMS): Merging the Internet And the Cellular Worlds, J. Wiley & Sons.10.1002/9780470695135 ↗
2. Olsson, U., Mulligan, C., Fikouras, I., Ryde, A., Stille, M., and Noldus, R. (2011). IMS Application Developer’s Handbook, Academic Press.
3. Copeland, R. (2008). Converging NGN Wireline and Mobile 3G Networks with IMS, Auerbach Publications.10.1201/9781420013788 ↗
4. Ahson, S., and Ilyas, M. (2009). IP Multimedia Subsystem (IMS) Handbook, CRC Press.10.1201/9781420064612 ↗
5. Li, J.W., Jan, Y.S., and Chang, Y.C. (2016, January 10–14). Multimedia synchronization on IP multimedia subsystem to support collaborative learning. Proceedings of the 2016 5th IIAI International Congress on Advanced Applied Informatics, IIAI-AAI 2016, Kumamoto, Japan.10.1109/IIAI-AAI.2016.65 ↗
6. OSGi (2018, October 22). Open Service Gateway Initiative (OSGi): The Dynamic Module System for Java. Available online: https://www.osgi.org/.
7. Design and Implementation of an IoT Access Point for Smart Home10.3390/app5041882 ↗
8. Cheng, B., and Wei, Z. (2014). Restful m2m gateway for remote wireless monitoring for district central heating networks. Sensors, 22447–22470.10.3390/s141222447 ↗
9. Majority-consensus fusion approach for elderly IoT-based healthcare applications10.1007/s12243-016-0550-7 ↗
10. IP home gateway as universal multi-purpose enabler for smart home services10.1007/s00502-014-0209-x ↗
11. Bhatti, J., Van Den Wouwer, D., Kerckhove, W., Dupont, T., and Volckaert, B. (2016, January 23–25). A scalable software framework for real-Time data processing in the railway environment. Proceedings of the 2016 IEEE International Conference on Intelligent Rail Transportation, ICIRT 2016, Birmingham, UK.10.1109/ICIRT.2016.7588728 ↗
12. Jeong, Y., Son, S., Jeong, E., Lee, B., Jeong, Y., Son, S., Jeong, E., and Lee, B. (2018). An Integrated Self-Diagnosis System for an Autonomous Vehicle Based on an IoT Gateway and Deep Learning. Appl. Sci., 8.10.3390/app8071164 ↗
13. Lee, C.T., Shen, T.C., Lee, W.D., Lee, C.T., Shen, T.C., and Lee, W.D. (2017). A Novel Optical Morse Code-Based Electronic Lock Using the Ambient Light Sensor and Fuzzy Controller. Appl. Sci., 7.10.3390/app7020140 ↗
14. Lai, C.F., Chen, M., Vasilakos, A.V., and Huang, Y.M. (2010, January 6–10). Extending the DLNA-based multimedia sharing system to P2P network on OSGi frameworks. Proceedings of the GLOBECOM—IEEE Global Telecommunications Conference, Miami, FL, USA.10.1109/GLOCOM.2010.5683879 ↗
15. DLNA-based multimedia sharing system for OSGI framework with extension to P2P network10.1109/JSYST.2010.2047175 ↗
16. Andrade, J.C., Ribeiro, R.B., Villaca, R.S., Martinello, M., and Santos, C.A. (2018, January 16–18). SANGN: A new service oriented architecture for provisioning of NGN scalable multimedia services. Proceedings of the International Conference on Advanced Information Networking and Applications, AINA, Matsue, Japan.10.1109/AINA.2018.00080 ↗
17. Cabelino Ribeiro, R.B., Martinello, M., Santos, C.A.S., and Soares, R.B. (2015). An architectural framework for delivering SIP-AS multimedia services based on JADE/OSGi technology. Lecture Notes of the Institute for Computer Sciences, Social-Informatics and Telecommunications Engineering, LNICST, Springer.10.1007/978-3-319-18802-7_17 ↗
18. Rosenberg, J., Schulzrinne, H., Camarillo, G., Johnston, A., Peterson, J., Sparks, R., Handley, M., and Schooler, E. (2018, October 22). RFC 3261: SIP: Session Initiation Protocol. Available online: http://www.rfc-editor.org/info/rfc3261.
19. Architectural Styles and the Design of Network-based Software Architectures
20. Rosenberg, J., Schulzrinne, H., and Kyzivat, P. (2018, October 22). RFC 3840: Indicating User Agent Capabilities in the Session Initiation Protocol (SIP). Available online: https://datatracker.ietf.org/doc/rfc3840/.
21. Rosenberg, J., Schulzrinne, H., and Kyzivat, P. (2018, October 22). RFC 3841: Caller Preferences for the Session Initiation Protocol (SIP). Available online: https://www.rfc-editor.org/info/rfc3841.
22. Rosenberg, J. (2018, October 22). RFC 5688: A Session Initiation Protocol (SIP) Media Feature Tag for MIME Application Subtypes. Available online: https://www.rfc-editor.org/info/rfc5688.
23. Equinox, E. (2018, October 22). Eclipse Equinox-OSGi Core Framework. Available online: http://www.eclipse.org/equinox/.
24. O’Doherty, P., and Ranganathan, M. (2003). JAIN SIP Tutorial: Serving the Developer Community, Sun Microsystems.
25. Programming with the Java media framework