Improving End-To-End Latency Fairness Using a Reinforcement-Learning-Based Network Scheduler
Source abstract
Abstract
In services such as metaverse, which should provide a constant quality of service (QoS) regardless of the user’s physical location, the end-to-end (E2E) latency must be fairly distributed over any flow in the network. To this end, we propose a reinforcement learning (RL)-based scheduler for minimizing the maximum network E2E latency. The RL model used the double deep Q-network (DDQN) with the prioritized experience replay (PER). In order to see the performance change according to the type of RL agent, we implemented a single-agent environment where the controller is an agent and a multi-agent environment where each node is an agent. Since the agents were unable to identify E2E latencies in the multi-agent environment, the state and reward were formulated using the estimated E2E latencies. To precisely evaluate the RL-based scheduler, we set out benchmark algorithms to compare with which a network-arrival-time-based heuristic algorithm (NAT-HA) and a maximum-estimated-delay-based heuristic algorithm (MED-HA). The RL-based scheduler, first-in-first-out (FIFO), round-robin (RR), NAT-HA, and MED-HA were compared through large-scale simulations on four network topologies. The simulation results in fixed-packet generation scenarios showed that our proposal, the RL-based scheduler, achieved the minimization of maximum E2E latency in all the topologies. In other scenarios with random flow generation, the RL-based scheduler and MED-HA showed the lowest maximum E2E latency for all topologies. Depending on the topology, the maximum E2E latency of NAT-HA was equal to or larger than that of the RL-based scheduler. In terms of fairness, the RL-based scheduler showed a higher level of fairness than that of FIFO and RR. NAT-HA had similar or lower fairness than the RL-based scheduler depending on the topology, and MED-HA had the same level of fairness as the RL-based scheduler.
Source: crossref · Quality: baseline
Research context
OpenAlex topics: Image and Video Quality Assessment · Software-Defined Networks and 5G · IoT and Edge/Fog Computing
SciVX discovery tags are terminology-based. OpenAlex topics are source-provided classifications.
Affiliations
Department of AI & Informatics, Sangmyung University, Seoul 03016, Republic of Korea
Department of Human-Centered Artificial Intelligence, Sangmyung University, Seoul 03016, Republic of Korea
Funding
National Research Foundation of Korea
References (34)
Show source-provided references
1. Denda, R., Banchs, A., and Effelsberg, W. (2000, January 25–26). The Fairness Challenge in Computer Networks. Proceedings of the Quality of Future Internet Services, First COST 263 International Workshop, QofIS 2000, Berlin, Germany.10.1007/3-540-39939-9_17 ↗
2. Fairness in Wireless Networks:Issues, Measures and Challenges10.1109/SURV.2013.050113.00015 ↗
3. (2022, November 17). Segment Routing Architecture, IETF RFC 8402, July 2018. Available online: https://datatracker.ietf.org/doc/rfc8402/.
4. (2022, August 09). Deterministic Networking Architecture, IETF RFC 8655, October 2019. Available online: https://datatracker.ietf.org/doc/rfc8655/.
5. 6LB: Scalable and Application-Aware Load Balancing with Segment Routing10.1109/TNET.2018.2799242 ↗
6. Zero Jitter for Deterministic Networks Without Time-Synchronization10.1109/ACCESS.2021.3068515 ↗
7. (2022, August 12). Deterministic Networking (DetNet) Data Plane Framework, IETF RFC 8938, November 2020. Available online: https://www.rfc-editor.org/rfc/rfc8938.
8. Wang, P., Ma, S., Hongyi, L., Wang, Z., and Chen, L. (2015, January 19–22). Adaptive Remaining Hop Count Flow Control: Consider the Interaction between Packets. Proceedings of the 20th Asia and South Pacific Design Automation Conference, Chiba, Japan.
9. Alizadeh, M., Yang, S., Sharif, M., Katti, S., McKeown, N., Prabhakar, B., and Shenker, S. (2013, January 12–16). pFabric. Proceedings of the ACM SIGCOMM 2013 Conference on SIGCOMM, Hong Kong, China.10.1145/2486001.2486031 ↗
10. Sharma, N.K., Zhao, C., Liu, M., Kannan, P.G., Kim, C., Krishnamurthy, A., and Sivaraman, A. (2020, January 25–27). Programmable calendar queues for high-speed packet scheduling. Proceedings of the 17th USENIX Symposium on Networked Systems Design and Implementation (NSDI 20), Santa Clara, CA, USA.
11. Yu, Z., Hu, C., Wu, J., Sun, X., Braverman, V., Chowdhury, M., Liu, Z., and Jin, X. (2021, January 23–27). Programmable Packet Scheduling with a Single Queue. Proceedings of the 2021 ACM SIGCOMM 2021 Conference, Virtual.10.1145/3452296.3472887 ↗
12. Shrivastav, V. (2019, January 19–23). Fast, Scalable, and Programmable Packet Scheduler in Hardware. Proceedings of the ACM Special Interest Group on Data Communication, Beijing, China.10.1145/3341302.3342090 ↗
13. Kolhar, M. (2021). Using the Packet Header Redundant Fields to Improve VoIP Bandwidth Utilization. Electr. Electron. Eng., Preprints.10.20944/preprints202111.0025.v1 ↗
14. Dinda, P.A. (2002., January 1). Exploiting packet header redundancy for zero cost dissemination of dynamic resource information. Proceedings of the 6th Workshop on Languages, Compilers, and Run-Time Systems for Scalable Computer (LCR 2002), Washington, DC, USA.
15. Chen, J., Wang, Y., and Lan, T. (2021, January 10–13). Bringing Fairness to Actor-Critic Reinforcement Learning for Network Utility Optimization. Proceedings of the IEEE INFOCOM 2021–IEEE Conference on Computer Communications, Vancouver, BC, Canada.10.1109/INFOCOM42981.2021.9488823 ↗
16. López-Sánchez, M., Villena-Rodríguez, A., Gómez, G., Martín-Vega, F.J., and Aguayo-Torres, M.C. (2022). Latency Fairness Optimization on Wireless Networks through Deep Reinforcement Learning. arXiv.10.1109/TVT.2022.3224368 ↗
17. Jiang, J., and Lu, Z. (2019, January 8–14). Learning fairness in multi-agent systems. Proceedings of the Advances in Neural Information Processing Systems 32: Annual Conference on Neural Information Processing Systems 2019, Vancouver, BC, Canada.
18. Nguyen, C.T., Van Huynh, N., Chu, N.H., Saputra, Y.M., Hoang, D.T., Nguyen, D.N., Pham, Q.-V., Niyato, D., Dutkiewicz, E., and Hwang, W.-J. (2021). Transfer Learning for Future Wireless Networks: A Comprehensive Survey. arXiv.10.1109/JPROC.2022.3175942 ↗
19. Deep Learning for Wireless Networking: The Next Frontier10.1109/MWC.001.2100005 ↗
20. Adaptive Packet Scheduling in IoT Environment Based on Q-Learning10.1016/j.procs.2018.10.178 ↗
21. Deep-Q-Network-Based Multimedia Multi-Service QoS Optimization for Mobile Edge Computing Systems10.1109/ACCESS.2019.2951219 ↗
22. Marchang, J., Ghita, B., and Lancaster, D. (2013, January 15–18). Hop-Based Dynamic Fair Scheduler for Wireless Ad-Hoc Networks. Proceedings of the 2013 IEEE International Conference on Advanced Networks and Telecommunications Systems (ANTS), Kattankulathur, India.10.1109/ANTS.2013.6802873 ↗
23. Lee, E.M., Kashif, A., Lee, D.H., Kim, I.T., and Park, M.S. (2010, January 7–10). Location based multi-queue scheduler in wireless sensor network. Proceedings of the 2010 the 12th International Conference on Advanced Communication Technology (ICACT), Gangwon-Do, Republic of Korea.
24. Peng, Y., Liu, Q., and Varman, P. (2019, January 15–17). Latency Fairness Scheduling for Shared Storage Systems. Proceedings of the 2019 IEEE International Conference on Networking, Architecture and Storage (NAS), Enshi, China.10.1109/NAS.2019.8834732 ↗
25. Q-Learning10.1007/BF00992698 ↗
26. Mnih, V., Kavukcuoglu, K., Silver, D., Graves, A., Antonoglou, I., Wierstra, D., and Riedmiller, M. (2013). Playing Atari with Deep Reinforcement Learning. arXiv.
27. Van Hasselt, H., Guez, A., and Silver, D. (2016, January 12–17). Deep Reinforcement Learning with Double Q-Learning. Proceedings of the AAAI Conference on Artificial Intelligence, Phoenix, AZ, USA.10.1609/aaai.v30i1.10295 ↗
28. Hasselt, H. (2010, January 6–9). Double Q-learning. Proceedings of the Advances in Neural Information Processing Systems 23: 24th Annual Conference on Neural Information Processing Systems 2010, Vancouver, BC, Canada.
29. Schaul, T., Quan, J., Antonoglou, I., and Silver, D. (2015). Prioritized Experience Replay. arXiv.
30. Tan, M. (1993, January 27–29). Multi-agent reinforcement learning: Independent vs. cooperative agents. Proceedings of the Tenth International Conference on Machine Learning, Amherst, MA, USA.10.1016/B978-1-55860-307-3.50049-6 ↗
31. Time-Sensitive Networking Task Group (2022, August 23). IEEE802.org. Available online: https://www.ieee802.org/1/pages/tsn.html.
32. Jain, R., Chiu, D., and Hawe, W. (1998). A Quantitative Measure of Fairness and Discrimination For Resource Allocation in Shared Computer Systems. arXiv.
33. (2022, May 13). TensorFlow. Available online: https://www.tensorflow.org/?hl=ko.
34. Asynchronous Deterministic Network Based on the DiffServ Architecture10.1109/ACCESS.2022.3146398 ↗