journal article·2023-04-13Open access

RPL-Based IoT Networks under Simple and Complex Routing Security Attacks: An Experimental Study

Ibrahim S. Alsukayti, Mohammed Alreshoodi

Applied Sciences· Volume 13· Issue 8

Abstract

Effective security support still remains a challenge even for a standardized Internet of Things network protocol such as the IPv6 Routing Protocol for Low-Power and Lossy Networks (RPL). It provides limited protection against external security attacks but stays highly vulnerable to internal routing attacks. The inherent RPL design of RPL, particularly its topology establishment and maintenance mechanism, makes it easy to initiate such kinds of attacks which target overall network performance and topology stability. Establishing a firm and practical understanding of the impacts of these attacks on RPL networks is still critically needed for further investigation. This is more demanding when considering varying-scale RPL deployments targeted by complex attack scenarios. In this research work, an extensive experimental study of these critical RPL routing attacks considering simple-to-complex attack scenarios in varying-scale RPL network setups is presented. It provides a practical contribution toward experimentally understanding the effectiveness of internal routing attacks when targeting RPL-based IoT networks. The main objective is to provide future research works with a practical reference to the effectiveness of these security attacks and the overall performance of RPL networks under routing attacks. The results indicate the adverse impacts of routing attacks on the overall performance of RPL networks. Even in simple attack scenarios, it was found that the attacked networks experienced noticeable degradation in QoS performance and topology stability. In addition, the attacks incurred considerable increases in energy consumption and control traffic overhead. These were more evident in large-scale experimental setups and also under composite and hybrid routing attacks. QoS performance and topology stability degraded by more than 90% whereas energy consumption and network overhead increased by more than 200%.
Source: crossref · Quality: baseline

Research context

OpenAlex topics: Network Security and Intrusion Detection · Software-Defined Networks and 5G · Smart Grid Security and Resilience

SciVX discovery tags are terminology-based. OpenAlex topics are source-provided classifications.

Affiliations

Department of Computer Science, College of Computer, Qassim University, Buraydah 51452, Saudi Arabia

Unit of Scientific Research, Applied College, Qassim University, Buraydah 52571, Saudi Arabia

Funding

Qassim University

References (56)

Show source-provided references
1. Vermesan, O., and Friess, P. (2022). Internet of Things: Converging Technologies for Smart Environments and Integrated Ecosystems, River Publishers.
2. Al-rawashdeh, M., Keikhosrokiani, P., Belaton, B., Alawida, M., and Zwiri, A. (2022). IoT Adoption and Application for Smart Healthcare: A Systematic Review. Sensors, 22.10.3390/s22145377 ↗
3. A Survey on the Role of IoT in Agriculture for the Implementation of Smart Livestock Environment10.1109/ACCESS.2022.3142848 ↗
4. Sujey, L. (2023, January 15). Number of Internet of Things (IoT) Connected Devices Worldwide in 2018, 2025 and 2030. Available online: https://www.statista.com/statistics/802690/worldwide-connected-devices-by-access-technology/.
5. Manyika, J., Chui, M., Bisson, P., Woetzel, J., Dobbs, R., Bughin, J., and Aharon, D. (2015). The Internet of Things: Mapping the Value beyond the Hype, McKinsey Global Institute.
6. Dohler, M., Watteyne, T., Winter, T., and Barthel, D. (2009). Routing Requirements for Urban Low-Power and Lossy Networks, IETF. IETF RFC 5548.10.17487/rfc5548 ↗
7. Pister, K., Thubert, P., Dwars, S., and Phinney, T. (2009). Industrial Routing Requirements in Low-Power and Lossy Networks, IETF. IETF RFC 5673.
8. Martocci, J., Mil, P.D., Riou, N., and Vermeylen, W. (2010). Building Automation Routing Requirements in Low-Power and Lossy Networks, IETF. IETF RFC 5867.
9. Brandt, A., Buron, J., and Porcu, G. (2010). Home Automation Routing Requirements in Low-Power and Lossy Networks, IETF. IETF RFC 5826.10.17487/rfc5826 ↗
10. Winter, T., Thubert, P., Brandt, A., Hui, J., Kelsey, R., Levis, P., Pister, K., Struik, R., Vasseur, J., and Alexander, R. (2012). RPL: IPv6 Routing Protocol for Low-Power and Lossy Networks, IETF. IETF RFC 6550.10.17487/rfc6550 ↗
11. Tsao, T., Alexander, R., Dohler, M., Daza, V., Lozano, A., and Richardson, M. (2015). A Security Threat Analysis for the Routing Protocol for Low-Power and Lossy Networks (RPLs), IETF. IETF RFC 7416.10.17487/rfc7416 ↗
12. Perazzo, P., Vallati, C., Arena, A., Anastasi, G., and Dini, G. (2017, January 20–22). An Implementation and Evaluation of the Security Features of RPL. Proceedings of the 16th International Conference Ad-Hoc Networks and Wireless, Messina, Italy.10.1007/978-3-319-67910-5_6 ↗
13. Enhancing Routing Security in IoT: Performance Evaluation of RPL’s Secure Mode Under Attacks10.1109/JIOT.2020.3022276 ↗
14. A Taxonomy of Attacks in RPL-based Internet of Things
15. Assessment of Routing Attacks and Mitigation Techniques with RPL Control Messages: A Survey10.1145/3494524 ↗
16. DDoS Attacks in IoT Networks: A Comprehensive Systematic Literature Review10.1007/s11280-020-00855-2 ↗
17. Pongle, P., and Chavan, G. (2015, January 8–10). A survey: Attacks on RPL and 6LoWPAN in IoT. Proceedings of the International Conference on Pervasive Computing (ICPC), Pune, India.10.1109/PERVASIVE.2015.7087034 ↗
18. Altulaihan, E., Almaiah, M.A., and Aljughaiman, A. (2022). Cybersecurity Threats, Countermeasures and Mitigation Techniques on the IoT: Future Research Directions. Electronics, 11.10.3390/electronics11203330 ↗
19. Morgan, S. (2023, January 15). Global Cybersecurity Spending Predicted to Exceed \$1 Trillion From 2017–2021. Cybercrime Magazine, June 2019. Available online: https://cybersecurityventures.com/cybersecurity-market-report/.
20. Kushalnagar, N., Montenegro, G., Hui, J., and Culler, D. (2007). Transmission of IPv6 Packets over IEEE 802.15.4 Networks, IETF. IETF RFC 4944.10.17487/rfc4944 ↗
21. Hui, J., and Thubert, P. (2011). Compression Format for IPv6 Datagrams over IEEE 802.15.4-Based Networks, IETF. IETF RFC 6282.10.17487/rfc6282 ↗
22. Vasseur, J.P., Kim, M., Pister, K., Dejean, N., and Barthel, D. (2012). Routing Metrics Used for Path Calculation in Low-Power and Lossy Networks, IETF. IETF RFC 6551.
23. Thubert, P. (2012). Objective Function Zero for the Routing Protocol for Low-Power and Lossy Networks (RPL), IETF. IETF RFC 6552.10.17487/rfc6552 ↗
24. Gnawali, O., and Levis, P. (2012). The Minimum Rank with Hysteresis Objective Function, IETF. IETF RFC 6719.10.17487/rfc6719 ↗
25. Levis, P., Clausen, T., Hui, J., Gnawali, O., and Ko, J. (2011). The Trickle Algorithm, IETF. IETF RFC 6206.10.17487/rfc6206 ↗
26. Avila, K., Jabba, D., and Gomez, J. (2020). Security Aspects for RPL-Based Protocols: A Systematic Review in IoT. Appl. Sci., 10.10.3390/app10186472 ↗
27. Security of the Internet of Things: Vulnerabilities, Attacks, and Countermeasures10.1109/COMST.2019.2953364 ↗
28. Security of RPL based 6LoWPAN Networks in the Internet of Things: A Review10.1109/JSEN.2020.2973677 ↗
29. Routing Attacks and Mitigation Methods for RPL-Based Internet of Things10.1109/COMST.2018.2885894 ↗
30. Kumar, A., Matam, R., and Shukla, S. (2016, January 22–24). Impact of Packet Dropping Attacks on RPL. Proceedings of the 4th International Conference on Parallel, Distributed and Grid Computing (PDGC), Waknaghat, India.10.1109/PDGC.2016.7913211 ↗
31. Samuel, C., Alvarez, B.M., Ribera, E.G., Ioulianou, P.P., and Vassilakis, V.G. (2020, January 20–22). Performance Evaluation of a Wormhole Detection Method using Round-Trip Times and Hop Counts in RPL-Based 6LoWPAN Networks. Proceedings of the 12th International Symposium on Communication Systems, Networks and Digital Signal Processing (CSNDSP), Porto, Portugal.10.1109/CSNDSP49049.2020.9249612 ↗
32. Perazzo, P., Vallati, C., Varano, D., Anastasi, G., and Dini, G. (2018, January 6–8). Implementation of a Wormhole Attack Against a RPL Network: Challenges and Effects. Proceedings of the 14th Annual Conference on Wireless On-demand Network Systems and Services (WONS), Isola, France.10.23919/WONS.2018.8311669 ↗
33. An Experimental Study of Distributed Denial of Service and Sink Hole Attacks on IoT based Healthcare Applications10.1007/s11277-021-08657-z ↗
34. A Study on Impact of DIS flooding Attack on RPL-based 6LowPAN Network10.1016/j.micpro.2022.104675 ↗
35. Nguyen, T., Ngo, T., Nguyen, T., Tran, D., Tran, H.A., and Bui, T. (2018, January 27–31). The Flooding Attack in Low Power and Lossy Networks: A Case Study. Proceedings of the International Conference on Smart Communications in Network Technologies (SaCoNeT), El Oued, Algeria.10.1109/SaCoNeT.2018.8585451 ↗
36. Effect of DIS Attack on 6TiSCH Network Formation10.1109/LCOMM.2022.3155992 ↗
37. The DAO Induction Attack: Analysis and Countermeasure10.1109/JIOT.2021.3108154 ↗
38. The Impact of Copycat Attack on RPL based 6LoWPAN Networks in Internet of Things10.1007/s00607-020-00862-1 ↗
39. A Study of RPL DODAG Version Attacks
40. Aris, A., Oktug, S.F., and Berna Ors Yalcin, S. (2016, January 25–29). RPL Version Number Attacks: In-depth Study. Proceedings of the IEEE/IFIP Network Operations and Management Symposium, Istanbul, Turkey.10.1109/NOMS.2016.7502897 ↗
41. Ambarkar, S.S., and Shekokar, N. (May, January 29). Critical and Comparative Analysis of DoS and Version Number Attack in Healthcare IoT System. Proceedings of the First Doctoral Symposium of Natural Computing Research, Pune, India.
42. Arış, A., and Oktuğ, S.F. (2020, January 15–17). Analysis of the RPL Version Number Attack with Multiple Attackers. Proceedings of the International Conference on Cyber Situational Awareness, Data Analytics and Assessment (CyberSA), Dublin, Ireland.10.1109/CyberSA49311.2020.9139695 ↗
43. A Potential Flooding Version Number Attack Against RPL based IOT Networks
44. Performance Evaluation of Mobile RPL-based IoT Networks under Version Number Attack10.1016/j.comcom.2022.10.014 ↗
45. Impact Analysis of Rank Attack on RPL-Based 6LoWPAN Networks in Internet of Things and Aftermaths10.1007/s13369-022-07342-y ↗
46. The Impact of Rank Attack on Network Topology of Routing Protocol for Low-Power and Lossy Networks10.1109/JSEN.2013.2266399 ↗
47. Dogan, C., Yilmaz, S., and Sen, S. (2022, January 7–8). Analysis of RPL Objective Functions with Security Perspective. Proceedings of the 11th International Conference on Sensor Networks (SENSORNETS), Online Streaming.10.5220/0011011900003118 ↗
48. Security Explorations for Routing Attacks in Low Power Networks on Internet of Things10.1007/s11227-020-03471-z ↗
49. Hkiri, A., Karmani, M., and Machhout, M. (2022, January 22–25). The Routing Protocol for Low Power and Lossy Networks (RPL) under Attack: Simulation and Analysis. Proceedings of the 5th International Conference on Advanced Systems and Emergent Technologies (IC_ASET), Hammamet, Tunisia.10.1109/IC_ASET53395.2022.9765901 ↗
50. Analysis of Routing Attacks on RPL based 6LoWPAN Networks10.14257/ijgdc.2018.11.8.05 ↗
51. Le, A., Loo, J., Luo, Y., and Lasebae, A. (2013, January 7–10). The Impacts of Internal Threats Towards Routing Protocol for Low Power and Lossy Network Performance. Proceedings of the IEEE Symposium on Computers and Communications (ISCC), Split, Croatia.10.1109/ISCC.2013.6755045 ↗
52. (2022, November 03). Tmote Sky Datasheet, Moteiv Corporation. Available online: https://insense.cs.st-andrews.ac.uk/files/2013/04/tmote-sky-datasheet.pdf.
53. (2022, November 03). Zolertia, “Z1 Datasheet”, Zolertia Advancare, March 2010. Available online: http://zolertia.sourceforge.net/wiki/images/e/e8/Z1_RevC_Datasheet.pdf.
54. (2022, November 03). TelosB Datasheet, Document Part Number: 6020-0094-01 Rev B, Crossbow Technology Inc., San Jose, CA, USA. Available online: https://www.willow.co.uk/TelosB_Datasheet.pdf.
55. MICAz Wireless Measurement System Datasheet, Document Part Number: 6020-0060-04 Rev A, Crossbow Technology Inc.. Available online: http://courses.ece.ubc.ca/494/files/MICAz_Datasheet.pdf.
56. Dunkels, A., Gronvall, B., and Voigt, T. (2004, January 16–18). Contiki- a Lightweight and Flexible Operating System for Tiny Networked Sensors. Proceedings of the 29th Annual IEEE International Conference on Local Computer Networks, Tampa, FL, USA.