SENTINEL: A Secure and Efficient Authentication Framework for Unmanned Aerial Vehicles
Source abstract
Abstract
Extensive use of unmanned aerial vehicles (commonly referred to as a “drone”) has posed security and safety challenges. To mitigate security threats caused by flights of unauthorized drones, we present a framework called SENTINEL (Secure and Efficient autheNTIcation for uNmanned aErial vehicLes) under the Internet of Drones (IoD) infrastructure. SENTINEL is specifically designed to minimize the computational and traffic overheads caused by certificate exchanges and asymmetric cryptography computations that are typically required for authentication protocols. SENTINEL initially generates a flight session key for a drone having a flight plan and registers the flight session key and its flight plan into a centralized database that can be accessed by ground stations. The registered flight session key is then used as the message authentication code key to authenticate the drone by any ground station while the drone is flying. To demonstrate the feasibility of the proposed scheme, we implemented a prototype of SENTINEL with ECDSA, PBKDF2 and HMAC-SHA256. The experiment results demonstrated that the average execution time of the authentication protocol in SENTINEL was about 3.1 times faster than the “TLS for IoT” protocol. We also formally proved the security of SENTINEL using ProVerif that is an automatic cryptographic protocol verifier.
Source: crossref · Quality: baseline
Research context
OpenAlex topics: Advanced Authentication Protocols Security · User Authentication and Security Systems · Vehicular Ad Hoc Networks (VANETs)
SciVX discovery tags are terminology-based. OpenAlex topics are source-provided classifications.
Affiliations
Security Engineering Lab (27317), Department of Electrical and Computer Engineering, College of Information and Communication Engineering, Sungkyunkwan University (SKKU), Suwon 16419, Korea
Department of Computer Engineering, Myongji University, Yongin, Gyeonggi-do 17058, Korea
Data61, CSIRO, Marsfield 2122, Australia
Funding
Agency for Defense Development
References (32)
Show source-provided references
1. Symington, S. (2020, March 18). Amazon.com Has Officially Begun Drone Delivery. Available online: https://www.fool.com/investing/2016/12/20/amazoncom-has-officially-begun-drone-delivery.aspx.
2. Gang, J. (2020, March 18). Drone Use in the Entertainment Industry and Beyond. Available online: https://thebottomline.as.ucsb.edu/2018/09/drone-use-in-the-entertainment-industry-and-beyond.
3. Shear, M.D., and Schmidt, M.S. (2020, March 18). White House Drone Crash Described as a U.S. Worker’s Drunken Lark. Available online: https://www.nytimes.com/2015/01/28/us/white-house-drone.html.
4. Design and analysis of secure lightweight remote user authentication and key agreement scheme in Internet of drones deployment10.1109/JIOT.2018.2888821 ↗
5. TCALAS: Temporal Credential-Based Anonymous Lightweight Authentication Scheme for Internet of Drones Environment10.1109/TVT.2019.2911672 ↗
6. A lightweight authentication and key agreement scheme for internet of drones10.1016/j.comcom.2020.02.067 ↗
7. Lloyd, B., and Simpson, W. (2020, March 27). PPP Authentication Protocols. RFC 1334. Available online: https://tools.ietf.org/html/rfc1334/.
8. Simpson, W. (2020, March 27). PPP Challenge Handshake Authentication Protocol (CHAP). RFC 1994. Available online: https://tools.ietf.org/html/rfc1994/.
9. Aboba, B., Blunk, L., Vollbrecht, J., Carlson, J., and Levkowetz, H.E. (2020, March 27). Extensible Authentication Protocol (EAP). RFC 3748. Available online: https://www.hjp.at/doc/rfc/rfc3748.html.
10. (2020, March 27). The OCF Security Specification. Available online: https://openconnectivity.org/developer/specifications/.
11. (2020, March 27). IoTivity Wiki. Available online: https://iotivity.org/.
12. Sciancalepore, S., Capossele, A., Piro, G., Boggia, G., and Bianchi, G. (2015, January 18). Key Management Protocol with Implicit Certificates for IoT Systems. Proceedings of the Workshop on IoT Challenges in Mobile and Industrial Systems, Florence, Italy.10.1145/2753476.2753477 ↗
13. Porambage, P., Schmitt, C., Kumar, P., Gurtov, A., and Ylianttila, M. (2014, January 6–9). Two-phase authentication protocol for wireless sensor networks in distributed IoT applications. Proceedings of the IEEE Conference on Wireless Communications and Networking, Istanbul, Turkey.10.1109/WCNC.2014.6952860 ↗
14. Housley, R., Ford, W., Polk, W., and Solo, D. (2020, March 27). Internet X.509 Public Key Infrastructure Certificate and CRL Profile. RFC 2459. Available online: https://rfc-editor.org/rfc/rfc2459.txt.
15. Kwon, H., Raza, S., and Ko, J. (2018, January 4–8). POSTER: On Compressing PKI Certificates for Resource Limited Internet of Things Devices. Proceedings of the 2018 on Asia Conference on Computer and Communications Security, Incheon, Korea.10.1145/3196494.3201591 ↗
16. Internet of Drones10.1109/ACCESS.2016.2537208 ↗
17. Security and Privacy for the Internet of Drones: Challenges and Solutions10.1109/MCOM.2017.1700390 ↗
18. Ni, J., Lin, X., Zhang, K., and Shen, X. (2016, January 18–21). Privacy-preserving real-time navigation system using vehicular crowdsourcing. Proceedings of the 2016 IEEE 84th Vehicular Technology Conference (VTC-Fall), Montréal, QC, Canada.10.1109/VTCFall.2016.7881177 ↗
19. Efficient privacy-preserving authentication framework for edge-assisted Internet of Drones
20. (2020, March 28). Greenpeace Crashes Superman-Shaped Drone into French Nuclear Plant. Available online: https://www.reuters.com/article/us-france-nuclear-greenpeace/greenpeace-crashes-superman-shaped-drone-into-french-nuclear-plant-idUSKBN1JT1JM.
21. (2020, March 28). Gatwick Airport Drone Incident. Available online: https://en.wikipedia.org/wiki/Gatwick_Airport_drone_incident.
22. (2020, March 28). Drone Filmed People’s Pin Codes at Co Antrim ATM. Available online: https://www.belfasttelegraph.co.uk/news/northern-ireland/drone-filmed-peoples-pin-codes-at-co-antrim-atm-34945847.html.
23. Certificateless cryptographic protocols for efficient drone-based smart city applications10.1109/ACCESS.2017.2684128 ↗
24. Chen, C.L., Deng, Y.Y., Weng, W., Chen, C.H., Chiu, Y.J., and Wu, C.M. (2020). A traceable and privacy-preserving authentication for UAV communication control system. Electronics, 9.10.3390/electronics9010062 ↗
25. On the security of public key protocols10.1109/TIT.1983.1056650 ↗
26. Kaliski, B. (2000). PKCS# 5: Password-Based Cryptography Specification Version 2.0, RSA Laboratories. Available online: https://tools.ietf.org/html/rfc2898/.10.17487/rfc2898 ↗
27. Berges, P.M. (2019). Exploring the Vulnerabilities of Traffic Collision Avoidance Systems (TCAS) Through Software Defined Radio (SDR) Exploitation. [Ph.D. Thesis, Virginia Tech].
28. The Elliptic Curve Digital Signature Algorithm (ECDSA)10.1007/s102070100002 ↗
29. Suárez-Albela, M., Fernández-Caramés, T.M., Fraga-Lamas, P., and Castedo, L. (2018, January 4–7). A Practical Performance Comparison of ECC and RSA for Resource-Constrained IoT Devices. Proceedings of the Global Internet of Things Summit, Bilbao, Spain.10.1109/GIOTS.2018.8534575 ↗
30. Automatic verification of correspondences for security protocols10.3233/JCS-2009-0339 ↗
31. Bhargavan, K., Blanchet, B., and Kobeissi, N. (2017, January 22–26). Verified Models and Reference Implementations for the TLS 1.3 Standard Candidate. Proceedings of the IEEE Symposium on Security and Privacy, San Jose, CA, USA.10.1109/SP.2017.26 ↗
32. Kobeissi, N., Bhargavan, K., and Blanchet, B. (2017, January 26–28). Automated Verification for Secure Messaging Protocols and their Implementations: A Symbolic and Computational Approach. Proceedings of the IEEE European Symposium on Security and Privacy, Paris, France.10.1109/EuroSP.2017.38 ↗