journal article·2022Open access

Leveraging Active Decremental TTL Measuring for Flexible and Efficient NAT identification

Tao Yang, Chengyu Wang, Tongqing Zhou, Zhiping Cai, Kui Wu, Bingnan Hou

Computers, Materials & Continua· Volume 70· Issue 3

Abstract

Malicious attacks can be launched by misusing the network address translation technique as a camouflage. To mitigate such threats, network address translation identification is investigated to identify network address translation devices and detect abnormal behaviors. However, existing methods in this field are mainly developed for relatively small-scale networks and work in an offline manner, which cannot adapt to the real-time inference requirements in high-speed network scenarios. In this paper, we propose a flexible and efficient network address translation identification scheme based on actively measuring the distance of a round trip to a target with decremental time-to-live values. The basic intuition is that the incoming and outgoing traffic from a network address translation device usually experiences the different number of hops, which can be discovered by probing with dedicated time-to-live values. We explore a joint effort of parallel transmission, stateless probes, and flexible measuring reuse to accommodate the efficiency of the measuring process. We further accelerate statistical counting with a new sublinear space data structure Bi-sketch. We implement a prototype and conduct real-world deployments with 1000 volunteers in 31 Chinese provinces, which is believed to bring insight for ground truth collection in this field. Experiments on multi-sources datasets show that our proposal can achieve as high precision and recall as 95% with a traffic handling throughput of over 106 pps.
Source: openalex_inverted_index · Quality: baseline

Research context

OpenAlex topics: Network Security and Intrusion Detection · Internet Traffic Analysis and Secure E-voting · Anomaly Detection Techniques and Applications

SciVX discovery tags are terminology-based. OpenAlex topics are source-provided classifications.

References (31)

Show source-provided references
1. P. Srisuresh, and M. Holdrege, “RFC 2663: IP network address translator (NAT) terminology and considerations, internet engineering task force,” 1999. [Online]. Available: http://www.rfc-editor.org/rfc/rfc2663.txt.10.17487/rfc2663 ↗
2. Can we identify NAT behavior by analyzing traffic flows?
3. On the impact of dynamic addressing on malware propagation
4. Remote NAT detect algorithm based on support vector machine
5. An identification method of PCs behind NAT router with proxy authentication on HTTP communication
6. A technique for counting NATed hosts
7. Remote physical device fingerprinting10.1109/TDSC.2005.26 ↗
8. Inferring carrier-grade NAT deployment in the wild
9. A flow-based entropy characterization of a NATed network and its application on intrusion detection
10. No NAT'd user left behind: fingerprinting users behind nat from netflow records alone
11. A network traffic classification model based on metric learning10.32604/cmc.2020.09802 ↗
12. Using object detection network for malware detection and identification in network traffic packets10.32604/cmc.2020.010091 ↗
13. An improved data stream summary: The count-min sketch and its applications10.1016/j.jalgor.2003.12.001 ↗
14. Mv-sketch: A fast and compact invertible sketch for heavy flow detection in network data streams
15. J. Postel, “RFC 0791: Internet protocol, internet engineering task force,” 1981. [Online]. Available: http://www.rfc-editor.org/rfc/rfc791.txt.
16. An overview of os fingerprinting tools on the internet
17. R. Braden, “RFC 1122: Requirements for internet hosts-communication layers, internet engineering task force,” 1989. [Online]. Available: http://www.rfc-editor.org/rfc/rfc1122.txt.10.17487/rfc1122 ↗
18. Measurements on delay and hop-count of the internet
19. Nat revelio: Detecting nat444 in the isp
20. Analysis and topology-based traversal of cascaded large-scale NATs
21. Internet-scale ipv4 alias resolution with midar10.1109/TNET.2012.2198887 ↗
22. A. M. Mandalari, A. Lutu, A. Dhamdhere, M. Bagnulo and K. C. Claffy, “Tracking the big nat across Europe and the us,” arXiv preprint, 2017. [Online]. Available: https://arxiv.org/abs/1704.01296.
23. Nmap: A novel neighborhood preservation space-filling algorithm10.1109/TVCG.2014.2346276 ↗
24. A parallel joint optimized relay selection protocol for wake-up radio enabled WSNs10.1016/j.phycom.2021.101320 ↗
25. BTS: A blockchain-based trust system to deter malicious data reporting in intelligent internet of things10.1109/JIOT.2021.3091883 ↗
26. Space/time trade-offs in hash coding with allowable errors10.1145/362686.362692 ↗
27. J. Rosenberg, R. Mahy, P. Matthews and D. Wing, “RFC 5389: Session traversal utilities for NAT, internet engineering task force,” 2008. [Online]. Available: http://www.rfc-editor.org/rfc/rfc5389.txt.10.17487/rfc5389 ↗
28. Analysis of the development of wechat mini program
29. Detection and characterization of network anomalies in large-scale RTT time series10.1109/TNSM.2021.3050495 ↗
30. An alias resolution method based on delay sequence analysis10.32604/cmc.2020.09850 ↗
31. “Measurement Lab, The M-lab NDT dataset, Measurement Lab Organization,” 2021. [Online]. Available: https://measurementlab.net/tests/ndt.