The Impact of Domain Name Server (DNS) over Hypertext Transfer Protocol Secure (HTTPS) on Cyber Security: Limitations, Challenges, and Detection Techniques
Source abstract
Abstract
The DNS over HTTPS (Hypertext Transfer Protocol Secure) (DoH) is a new technology that encrypts DNS traffic, enhancing the privacy and security of end-users. However, the adoption of DoH is still facing several research chall... | Find, read and cite all the research you need on Tech Science Press
Source: openalex_inverted_index · Quality: baseline
Research context
OpenAlex topics: Network Security and Intrusion Detection · IPv6, Mobility, Handover, Networks, Security · Network Packet Processing and Optimization
SciVX discovery tags are terminology-based. OpenAlex topics are source-provided classifications.
References (79)
Show source-provided references
1. RFC 9147: The datagram transport layer security (DTLS) protocol version 1.3
2. A comprehensive survey on DNS tunnel detection10.1016/j.comnet.2021.108322 ↗
3. Summary of DNS over HTTPS abuse10.1109/ACCESS.2022.3175497 ↗
4. DNSCrypt, “dnscrypt-proxy,” GitHub. DNSCrypt GitHub Repository. Mar. 25, 2023.
5. A survey on DNS encryption: Current development, malware misuse, and inference techniques10.1145/3547331 ↗
6. Comparative analysis of DoT and HTTPS certificate ecosystems
7. F. J. Nijeboer, “Detection of HTTPS encrypted DNS traffic,” Bachelor’s thesis, Dept. of Electrical Engineering, Mathematics and Computer Science, Univ. of Twente, Enschede, Netherlands, 2020.
8. Origins of the domain name system10.1109/MAHC.2019.2913116 ↗
9. DNS privacy in practice and preparation
10. An empirical study of the cost of DNS-over-HTTPS
11. IETF, “DNS queries over HTTPS (DoH)-request for comments 8484,” 2018. Accessed: Mar. 26, 2023. [Online]. Available: https://tools.ietf.org/html/rfc8484
12. Cloudflare, “Connecting apps in cloudflare one,” Accessed: Mar. 23, 2023. [Online]. Available: https://developers.cloudflare.com/cloudflare-one/connections/connect-apps
13. Facebook, “doh-proxy,” Accessed: Mar. 25, 2023. [Online]. Available: https://github.com/facebookexperimental/doh-proxy
14. DNS tunneling: A review on features10.14419/ijet.v7i3.20.17266 ↗
15. Detecting malicious DNS queries over encrypted tunnels using statistical analysis and bi-directional recurrent neural networks
16. An investigation on information leakage of DNS over TLS
17. The role of artificial intelligence and machine learning in wireless networks security: Principle, practice and challenges10.1007/s10462-022-10143-2 ↗
18. Behavior-based tracking: Exploiting characteristic patterns in DNS traffic10.1016/j.cose.2013.03.012 ↗
19. Using machine learning for DNS over HTTPS detection
20. Performance assessment and analysis of DNS tunneling tools10.1093/jigpal/jzs029 ↗
21. A comparative performance evaluation of DNS tunneling tools
22. A DNS tunneling detection method based on deep learning models to prevent data exfiltration
23. Malicious network traffic detection for DNS over HTTPS using machine learning algorithms
24. NextDNS, “The new firewall for the modern Internet,” Accessed: Mar. 20, 2024. [Online]. Available: https://nextdns.io/
25. P. Wu, “Understanding DNS encryption,” Cloudflare Blog. Accessed: Jun. 28, 2023. [Online]. Available: https://blog.cloudflare.com/dns-encryption-explained/
26. S. Siby, M. Juarez, C. Diaz, N. Vallina-Rodriguez, and C. Troncoso, “Encrypted DNS→ privacy? A traffic analysis perspective,” 2019, arXiv:1906.09682.10.14722/ndss.2020.24301 ↗
27. Finding disposable domain names: A linguistics-based stacking approach10.1016/j.comnet.2020.107642 ↗
28. One to rule them all? A first look at DNS over QUIC
29. Comparing the effects of domain name system, DNS over transport layer security, and DNS over HTTPS on web performance
30. How DNS over HTTPS is reshaping privacy, performance, and policy in the internet ecosystem
31. A comprehensive measurement-based investigation of DNS hijacking
32. Leveraging eBPF to preserve user privacy for DNS, DoT, and DoH queries
33. An end-to-end, large-scale measurement of DNS-over-encryption: How far have we come?
34. A comprehensive study of DNS-over-HTTPS downgrade attack
35. User expectations and understanding of encrypted DNS settings
36. M. Vale and A. Dupuy, “Google public DNS over HTTPS (DoH) supports RFC 8484 standard,” google security blog. 2019. Accessed: Jul. 21, 2023. [Online]. Available: https://security.googleblog.com/2019/06/google-public-dns-over-https-doh.html
37. S. García, K. Hynek, D. Vekshin, T. Cejka, and A. Wasicek, “Large scale measurement on the adoption of encrypted DNS,” 2021, arXiv:2107.04436.
38. The DNS in IoT: Opportunities, risks, and challenges10.1109/MIC.2020.3005388 ↗
39. Network intrusion detection system (NIDS) based on pseudo-Siamese stacked autoencoders in fog computing10.1109/TSC.2023.3319953 ↗
40. C. López Romera, “DNS over HTTPS traffic analysis and detection,” M.S. thesis, Dept. Informatics, Universitat Oberta de Catalunya (UOC), Spain, 2020.
41. Encrypted and covert DNS queries for botnets: Challenges and countermeasures10.1016/j.cose.2019.101614 ↗
42. A DNS-based anti-phishing approach
43. Privacy illusion: Beware of unpadded DoH
44. Aijaz · Data Science and Security · 2021 · 79
45. A comprehensive study of phishing attacks
46. Poster: Off-path DNSSEC downgrade attacks
47. An insight into encrypted DNS protocol: DNS over TLS
48. A first look at QNAME minimization in the domain name system
49. Clouding up the internet: How centralized is DNS traffic becoming?
50. Understanding the security of free content websites by analyzing their SSL certificates: A comparative study
51. Identifying malicious DNS tunnel tools from DoH traffic using hierarchical machine learning classification
52. DoH insight: Detecting DNS over HTTPS by machine learning
53. Detecting malicious DNS over HTTPS traffic using machine learning
54. Exploring simple detection techniques for DNS-over-HTTPS tunnels
55. Detection of DoH traffic tunnels using deep learning for encrypted traffic classification10.3390/computers12030047 ↗
56. Detection of DoH tunnels using time-series classification of encrypted traffic
57. SAC109—The implications of DNS over HTTPS and DNS over TLS
58. Can encrypted DNS be fast?
59. Detection of DoH tunneling using semi-supervised learning method
60. How private is Android’s private DNS setting? Identifying apps by encrypted DNS traffic
61. Evading DoH via live memory forensics for phishing detection and content filtering
62. M. MontazeriShatoori, “An anomaly detection framework for DNS-over-HTTPS (DoH) tunnel using time-series analysis,” Ph.D. thesis, University of New Brunswick, Canada, 2020.
63. Detecting malicious DNS over HTTPS traffic in domain name system using machine learning classifiers
64. Peek inside the encrypted world: Autoencoder-based detection of DoH resolvers
65. Generalized classification of DNS over HTTPS traffic with deep learning
66. DoH tunneling detection system for enterprise network using deep learning technique
67. P. Mockapetris, “Domain names-implementation and specification,” RFC 1035, Internet Engineering Task Force, Nov. 1987. Accessed: Jul. 21, 2023. [Online]. Available: https://datatracker.ietf.org/doc/html/rfc103510.17487/rfc1035 ↗
68. A DNS-based data exfiltration traffic detection method for unknown samples
69. K. Xu, P. Butler, S. Saha, and D. Yao, “DNS for massive-scale command and control,” IEEE Trans. Dependable Secur. Comput., vol. 10, no. 3, pp. 143–153, 2013. doi: 10.1109/TDSC.2013.10.10.1109/TDSC.2013.10 ↗
70. Comparative analysis of DNS over HTTPS detectors10.1016/j.comnet.2024.110452 ↗
71. Classifying DNS tunneling tools for malicious DoH traffic
72. Understanding the impact of encrypted domain name system on internet censorship
73. An ensemble framework for detection of DNS-over-HTTPS (DoH) traffic10.1007/s11042-023-16956-9 ↗
74. Detecting DNS hijacking by using NetFlow data
75. Behind closed doors: A network tale of spoofing, intrusion, and false DNS security
76. DNS over HTTPS detection using standard flow telemetry10.1109/ACCESS.2023.3275744 ↗
77. Detection and prevention of DNS spoofing attacks
78. Z. Hu, L. Zhu, J. Heidemann, A. Mankin, D. Wessels and P. Hoffman, “Specification for DNS over Transport Layer Security (TLS),” RFC 7858, RFC Editor. 2016. Accessed: Jun. 28, 2023. [Online]. Available: https://www.rfc-editor.org/rfc/rfc7858.html10.17487/RFC7858 ↗
79. A survey of domain name system vulnerabilities and attacks